ini_set() a wordpress

Pomoc w instalacji i konfiguracji, aktualne wersje i spolszczenia, porady Wordpress.
no avatar
Artand
Świeżak
 
Posty: 90
Reputacja: 1 pkt
Od: 27 lut 2013, o 04:35

ini_set() a wordpress

przez Artand » 1 mar 2013, o 17:10

Witam, od pewnego czasu borykam się z problemem na stronie kolegi. Mianowicie, ma on serwer u prywatnego usługodawcy i przy próbie instalacji WP po wpisaniu danych do bazy wyskakuje tylko białe tło.
Z tego co wiem to WP potrzebuje do działania funkcji ini_set(). Czy jest możliwość takiego ustawienia tego cms żeby z niej nie korzystał?

no avatar
admin
Administrator
 
Posty: 629
Reputacja: 38 pkt
Od: 30 sty 2013, o 17:39
Lokalizacja: Kraj nad Wisłą

Re: ini_set() a wordpress

przez admin » 1 mar 2013, o 17:46

Niestety, może "stety":) nie spotkałem się z takim przypadkiem, może spróbuj stworzyć stronę na localhoscie, bądź na innej domenie, następnie na tym serwerze, z którym są problemy stwórz bazę w phpmyadmin przekopiuj wyeksportowaną wcześniej bazę z localhosta zmieniając tylko adres oczywiście we wszystkich wystąpieniach http://localhost na adres http://docelowadomena.pl (najlepiej wszystko małymi literami) następnie przenieś pliki wordpressa z localhost przez ftp na docelową stronę i zmień plik config.php podając nowe namiary na bazę.

no avatar
1Frum3
Świeżak
 
Posty: 79
Reputacja: 0 pkt
Od: 21 lut 2013, o 09:45

Re: ini_set() a wordpress

przez 1Frum3 » 1 mar 2013, o 22:21

Wydaje mi się, że nawet instalacja nie została dokończona. Swojego czasu miałem podobny problem na Koomli. Z tego co pamiętam ten problem dotyczył wszystkich znanych CMS.

no avatar
Beenarile
Świeżak
 
Posty: 114
Reputacja: 3 pkt
Od: 22 lut 2012, o 19:54

Re: ini_set() a wordpress

przez Beenarile » 1 mar 2013, o 23:18

Chyba najlepszym i najpewniejszym sposobem na ten problem jest wyłączenie funkcji ini_set() w każdym pliku WP :)

no avatar
Lonsot
Świeżak
 
Posty: 84
Reputacja: 1 pkt
Od: 21 lut 2013, o 11:10

Re: ini_set() a wordpress

przez Lonsot » 2 mar 2013, o 00:04

Kiedyś na prywatnym serwerze również miałem ten problem. Tak jak to zostało opisane wyżej trzeba powyłączać wszystkie ini_set() w plikach .php. Trochę z tym zabawy, ale działa :)

no avatar
Artand
Świeżak
 
Posty: 90
Reputacja: 1 pkt
Od: 27 lut 2013, o 04:35

Re: ini_set() a wordpress

przez Artand » 2 mar 2013, o 11:31

Co macie na myśli mówiąc "wyłącz funkcję ini_set()"? Przecież na serwerze jest ona wyłączona i właśnie dlatego nie działa :/

no avatar
1Frum3
Świeżak
 
Posty: 79
Reputacja: 0 pkt
Od: 21 lut 2013, o 09:45

Re: ini_set() a wordpress

przez 1Frum3 » 2 mar 2013, o 12:02

Mając na myśli wyłączenie funkcji ini_set() chodziło o zakomentowanie w każdym pliku CMS linijki:
Kod: Zaznacz cały
@ini_set


Czyli ma wyglądać tak:
Kod: Zaznacz cały
//@ini_set

no avatar
Artand
Świeżak
 
Posty: 90
Reputacja: 1 pkt
Od: 27 lut 2013, o 04:35

Re: ini_set() a wordpress

przez Artand » 2 mar 2013, o 13:13

Ok, już rozumiem. Zrobiłem tak jak mówiłeś, ale pojawiają się literki: ďťż. Macie pomysł co z tym zrobić?

no avatar
1Frum3
Świeżak
 
Posty: 79
Reputacja: 0 pkt
Od: 21 lut 2013, o 09:45

Re: ini_set() a wordpress

przez 1Frum3 » 2 mar 2013, o 13:19

Sprawdź dokładnie czy we wszystkich plikach pozmieniałeś ta linijkę bo wszystko na to wskazuje, że coś zostawiłeś ;)

no avatar
Beenarile
Świeżak
 
Posty: 114
Reputacja: 3 pkt
Od: 22 lut 2012, o 19:54

Re: ini_set() a wordpress

przez Beenarile » 2 mar 2013, o 14:55

Artand napisał(a):Ok, już rozumiem. Zrobiłem tak jak mówiłeś, ale pojawiają się literki: ďťż. Macie pomysł co z tym zrobić?


Gdzieś musiałeś ominąć jakiś plik przy wyłączaniu tej funkcji. Jeżeli chcesz to szybko zrobić to polecam otworzyć wszystkie pliki w jednym edytorze do HTML/PHP i na każdym używać funkcji zamiany ciągu znaków. Będzie szybciej i dokładniej ;)

Następna strona



  • Podobne tematy
    Odpowiedzi
    Wyświetlone
    Ostatni post

Powrót do Instalacja i Konfiguracja Wordpress

Kto przegląda forum Wordpress

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość