Problem z adresem strony

Pomoc w instalacji i konfiguracji, aktualne wersje i spolszczenia, porady Wordpress.
no avatar
Kamil Guz
 
Posty: 6
Reputacja: 0 pkt
Od: 20 mar 2017, o 18:11
Lokalizacja: Polska

Problem z adresem strony

przez Kamil Guz » 20 mar 2017, o 18:19

Witam serdecznie. Nigdzie nie mogę znaleźć rozwiązania tego problemu.
Mianowicie użyłem automatycznego instalatora wordpress, który był zalecany przez hosting wordpressa.
Wordpress zainstalował się w folderze WP. Użyłem też tej nowej opcji umożliwiającej tworzenie sieci wytryn/kilku stron WP na jednym koncie/bazie...
Moja strona internetowa przez to działa tylko i wyłącznie z poziomu http://www.carebears.pl/wp/ a bez tego /wp wyświetla się adres hostingu.
Chciałbym aby strona działała normalnie na domenie http://www.carebears.pl.
W wordpressie powinna być opcja zmiany adresu strony lecz u mnie gdzieś ona wyparowała.
Tak wygląda to u mnie
Obrazek

A powinny być jeszcze 2 opcje między opisem a emailem jeżeli dobrze mówię.
Próbowałem też zmieniać adres wtyczkami
Velvet Blues Update URLs, Search and Replace i wszędzie wyświetla się, że zmiana adresu w bazie danych przebiegła pomyślnie ale nadal nic się nie dzieje.
Walczę z tym od wczoraj. Proszę o pomoc ;)

Avatar użytkownika
Fibbo
Świeżak
 
Posty: 119
Reputacja: 9 pkt
Od: 20 mar 2017, o 10:55

Re: Problem z adresem strony

przez Fibbo » 20 mar 2017, o 18:40

Jedną z możliwości jest edycja pliku wp-config.php, znajdującego się w główym folderze strony.

Do wp-config.php dodaj dwie linijki:
Kod: Zaznacz cały
define('WP_HOME','http://adrestwojejstrony.pl');
define('WP_SITEURL','adrestwojejstrony.pl');


Tylko zwróć uwagę na to by pod wskazanym adresem na serwerze, znajdował się wordpress. Inaczej uzyskasz "Internal Server Error".
Kamil Guz lubi ten wpis.
I <3 Wordpress.

no avatar
Kamil Guz
 
Posty: 6
Reputacja: 0 pkt
Od: 20 mar 2017, o 18:11
Lokalizacja: Polska

Re: Problem z adresem strony

przez Kamil Guz » 20 mar 2017, o 19:02

Niestety nic to nie pomogło. W katalogu www mam jeszcze index_forpsi o zawartości
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Forpsi.com</title>
<style type="text/css">
<!--
body {
margin-left: 0px;
margin-top: 0px;
margin-right: 0px;
margin-bottom: 0px;
}
.top_fondo {
background-repeat: repeat-x;
background-position: left top;
background-image: url(http://static.forpsi.com/zakaznici/img/top_fondo.gif);
background-color: #FFFFFF;
}
.bottom_fondo {
background-repeat: repeat-x;
background-position: left top;
background-color: #FEFEFE;
background-image: url(http://static.forpsi.com/zakaznici/img/bottom_fondo.gif);
}
.sfondo_laterale {
background-repeat: repeat-x;
background-position: left center;
}
.txt {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
line-height: 13px;
font-weight: normal;
color: #000000;
text-decoration: none;
padding-top:10px;
}
a:link {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
line-height: 15px;
font-weight: bold;
color: #000000;
text-decoration: none;
}
a:visited {
color: #000000;
text-decoration: none;
}
a:hover {
color: #FF0000;
text-decoration: none;
}
-->
</style>
</head>
<body>
<table width="100%" height="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td class="top_fondo" height="30%">&nbsp;</td>
</tr>
<tr>
<td height="1"><table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td background="http://static.forpsi.com/zakaznici/img/fondo_sx.gif" class="sfondo_laterale">&nbsp;</td>
<td width="1"><img src="http://static.forpsi.com/zakaznici/img/logo.gif" alt="Forpsi" border="0" usemap="#Map"></td>
<td width="275" background="http://static.forpsi.com/zakaznici/img/fondo_dx.gif" class="sfondo_laterale"><table width="100%" height="228" border="0" cellpadding="0" cellspacing="0">
<tr>
<td height="106" valign="bottom"><a href="http://www.forpsi.pl"><img src="http://static.forpsi.com/zakaznici/img/fondo_testo.gif" width="144" height="49" border="0"></a></td>
</tr>
<tr>
<td valign="top" class="txt">Domena <b><?php echo $_SERVER["HTTP_HOST"];?></b><br>
jest utrzymywana na serwerach <a href="http://www.forpsi.pl">FORPSI</a><br>
<br>
<i>Domain name <b><?php echo $_SERVER["HTTP_HOST"];?></b> run on <a href="http://www.forpsi.pl">FORPSI</a> servers</i></td>
</tr>
</table></td>
<td background="http://static.forpsi.com/zakaznici/img/fondo_dx.gif" class="sfondo_laterale">&nbsp;</td>
</tr>
</table></td>
</tr>
<tr>
<td class="bottom_fondo" height="70%">&nbsp;</td>
</tr>
</table>
<map name="Map">
<area shape="rect" coords="7,6,174,174" href="http://www.forpsi.pl" target="_parent">
</map>
</body>
</html>

To właśnie jest ta strona która odpala się zamiast głównej strony wordpressa. Czy to ma jakieś znaczenie?

Próbowałem też wrzucić index i htaccess wrzucić do folderu www i przekierować na /WP/ ale wtedy z kolei mam problem z tym że witryna działa pod domeną carebears.pl ale bez WWW. Bo po dopisaniu http://WWW.carebears.pl wyskakuje błąd połączenia z bazą danych
...
ale to i tak nic nie zmienia bo potem przekierowuje mnie na http://WWW.carebears.pl/wp

Avatar użytkownika
Fibbo
Świeżak
 
Posty: 119
Reputacja: 9 pkt
Od: 20 mar 2017, o 10:55

Re: Problem z adresem strony

przez Fibbo » 20 mar 2017, o 19:19

W takim razie ja Cię źle zrozumiałem albo Ty źle to opisałeś. :)
index_forpsi o tej zawartości odpowiada za stronę statyczną, generowaną przez dostawcę serwera. Zamiast pustej strony pojawia się tam ich logo, kilka zdań, że wiesz że domena jest przepięta i działa ok.

Z tego co teraz napisałes to cała instalacja i linki wskazują na folder wp.
Zaloguj się do bazy danych i w tabeli wp_options, 2 pierwsze rekordy to:
siteurl oraz home, powinny wskazywać na http://carebears.pl/wp , więc zamień to na http://carebears.pl/ .
Pamiętaj żeby na serwerze przerzucić wszystkie pliki wordpressa z WP do głównego katalogu twojej domeny, czyli nazwadomeny/public_html , a nie tak jak teraz jest nazwadomeny/public_html/wp .
I <3 Wordpress.

no avatar
Kamil Guz
 
Posty: 6
Reputacja: 0 pkt
Od: 20 mar 2017, o 18:11
Lokalizacja: Polska

Re: Problem z adresem strony

przez Kamil Guz » 20 mar 2017, o 19:50

Błąd łączenia się z bazą danych przerzuciłem wszystko do głównego folderu i zmieniłem te 2 rekordy ;)

Avatar użytkownika
Fibbo
Świeżak
 
Posty: 119
Reputacja: 9 pkt
Od: 20 mar 2017, o 10:55

Re: Problem z adresem strony

przez Fibbo » 20 mar 2017, o 20:07

W pliku wp-config.php masz DB_NAME, DB_USER, DB_PASSWORD, DB_HOST - te dane muszą być poprawne, upewnij się że na 100% są w porządku. Zwłaszcza DB_HOST, bo w specyficznych wypadkach serwerów nie zawsze jest to 'localhost' :)
+ sprawdź czy w wp-config.php nie masz nigdzie zdefiniowanego starego adresu, jeżeli tak to usuń z carebears.pl/wp, WP.

Coraz bliżej mety :)
I <3 Wordpress.

no avatar
Kamil Guz
 
Posty: 6
Reputacja: 0 pkt
Od: 20 mar 2017, o 18:11
Lokalizacja: Polska

Re: Problem z adresem strony

przez Kamil Guz » 20 mar 2017, o 20:44

/* Multisite */
define( 'WP_ALLOW_MULTISITE', true );
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'www.carebears.pl');
define('PATH_CURRENT_SITE', '/wp/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

Dane są poprawne a jak wracam do katalogu WP to z bazą wszystko ejst ok. tylko jak przeniosę to robi się problem z połączeniem ;D

Avatar użytkownika
Fibbo
Świeżak
 
Posty: 119
Reputacja: 9 pkt
Od: 20 mar 2017, o 10:55

Re: Problem z adresem strony

przez Fibbo » 20 mar 2017, o 21:12

Wkleiłeś rozwiązanie :)
define('PATH_CURRENT_SITE', '/wp/');

:P
I <3 Wordpress.

no avatar
Kamil Guz
 
Posty: 6
Reputacja: 0 pkt
Od: 20 mar 2017, o 18:11
Lokalizacja: Polska

Re: Problem z adresem strony

przez Kamil Guz » 20 mar 2017, o 21:26

Właśnie widzę ze nie napisałem czy trzeba to całe usunąć czy wpisać coś w to miejsce :P

Edit nic nie dało usunięcie całkiem
Ostatnio edytowano 20 mar 2017, o 21:29 przez Kamil Guz, łącznie edytowano 2 razy

Avatar użytkownika
Fibbo
Świeżak
 
Posty: 119
Reputacja: 9 pkt
Od: 20 mar 2017, o 10:55

Re: Problem z adresem strony

przez Fibbo » 20 mar 2017, o 21:28

Kod: Zaznacz cały
define('PATH_CURRENT_SITE', '/');
I <3 Wordpress.

Następna strona



  • Podobne tematy
    Odpowiedzi
    Wyświetlone
    Ostatni post

Powrót do Instalacja i Konfiguracja Wordpress

Kto przegląda forum Wordpress

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość