Customize - dlaczego nie działa

Dział poświęcony pozostałym kwestiom związanym z kodowaniem w CMS Wordpress.
no avatar
mia
 
Posty: 1
Reputacja: 0 pkt
Od: 29 wrz 2017, o 14:50

Customize - dlaczego nie działa

przez mia » 29 wrz 2017, o 14:56

Witam,
od wczoraj uczę się kodowania w wordpresie i mam pytanie, dlaczego poniższy kod nie działa? Tzn działa, ale pokazuje albo tylko Logo albo Tło - w zależności co jest niżej w kodzie.
Kod: Zaznacz cały
function agmor_customize_register($wp_customize){
   // Header Section
   $wp_customize->add_section('header', array(
      'title' => __('Nagłówek', 'Agmor Bootstrap'),
      'description'=> sprintf(__('Opcje nagłówka:', 'Agmor Bootstrap')),
      'priority' => 100
      ));

   $wp_customize -> add_setting('header_logo', array(
      'default' => get_bloginfo('template_directory').'/img/logo.png',
      'type' => 'theme_mod'

   ));

   $wp_customize -> add_control(new WP_Customize_Image_Control($wp_customize, 'Agmor Bootstrap', array(
      'label' => __( 'Logo', 'Agmor Bootstrap'),
      'section' => 'header',
      'settings' => 'header_logo',
      'priority' => 1
   )));


   $wp_customize -> add_setting('header_background', array(
      'default' => get_bloginfo('template_directory').'/img/bg-header.png',
      'type' => 'theme_mod'

   ));

    $wp_customize -> add_control(new WP_Customize_Image_Control($wp_customize, 'Agmor Bootstrap', array(
      'label' => __( 'Tło', 'Agmor Bootstrap'),
      'section' => 'header',
      'settings' => 'header_background',
      'priority' => 2
   )));
}


Jak kod powinien wyglądać prawidłowo, żeby obie opcje się pokazały. Pozdrawiam !



  • Podobne tematy
    Odpowiedzi
    Wyświetlone
    Ostatni post

Powrót do Kodowanie w Wordpressie

Kto przegląda forum Wordpress

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości

cron